
This chapter introduces the Windows Help application and user interface. It 
explains the basic features of Windows Help as they appear to users. Because the 
Help application will display the Help files you develop, you must understand 

Windows Help’s features from the user’s perspective.

Windows Help is a standard Windows-based application that displays online Help
files and is consistent with other applications that run in the Windows operating 
system. In addition to basic Windows skills, such as using the mouse, choosing 
menu commands, working with dialog boxes, using scroll bars, and so on, users 
must become familiar with unique elements of the Windows Help interface to use

Help effectively. The following sections describe those elements.

Most applications for Windows offer Help; generally, all you do to start Help is 
choose a command, such as Contents, from the application’s Help menu. You can
also press F1 at any time to start Help. Or you can use any of the other methods 
Windows offers for starting applications–the Run command in Program Manager 

or File Manager, for example.

The main Help window appears when a user requests Help, and it stays open until
the application or the user closes it. Information appears within the main Help 
window, which has the standard window elements: a title bar, a menu bar, a 
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button bar, a display area (with scrolling and nonscrolling regions), and scroll 
bars (Figure 1.1).

Graphic

Main Window Attributes

The first time the user requests Help, the main window appears in its default state
on the screen. The default settings determine the size, placement, and background
color of the main window. After the Help window displays, the user can change 
any of those attributes. Help authors can also define attributes for the main 
window that override the predefined defaults.

Title Bar
The title bar at the top of the Help window displays the name of the Help file or 
any title text that the author specifies in the [OPTIONS] or [WINDOWS] section 
of the Help project file (see Chapter 16, “The Help Project File,” for details). If 
the author doesn’t specify a title, “Windows Help” appears in the title bar (Figure
1.2).

Graphic
A Help title can have as many as 50 characters. Help centers the title in the 
available title bar width; however, if the user resizes the Help window so that the 
title text is wider than the window, the title is truncated from the right (Figure 
1.3).

Graphic
If the user opens a version 3.0 Help file, the title appears in Help 3.0 format: 
[Title string] Help - <Help filename.hlp>, as in Figure 1.4.

Graphic
Size
The initial size of the main Help window is approximately two-thirds of the total 
screen width. Windows Help reserves a 2-pixel space around the Help window 
borders to keep the window from jamming against the edge of the screen display. 
The default size is large enough to accommodate the Help button bar without 
forcing the standard buttons to wrap (Figure 1.5).
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Graphic

Note

To create international versions of Windows Help, the default 
size of the main window varies slightly depending on the length of the 
foreign-language text on the standard Help buttons. This variable is 
stored in the WINHELP.EXE resource file.

Users can resize the Help window, like other windows, by dragging the window 
borders or by using the Size command on the Control menu. They can also 
minimize or maximize the Help window. Any changes the user makes to the size 
of the main Help window are saved in the [Windows Help] section of the 
WIN.INI file.

Note

Because Help does not define minimum limits for the size of the
main window, the user can make the Help window so small that it is 
unusable.

Placement
When it first appears, the main window is positioned to the far right of the screen 
and extends the full height of the screen. Users can move the main window as 
they would move any other window in Windows–by dragging the title bar or by 
using the Move command on the Control menu. If the user moves the main 
window, the new position is recorded in the [Windows Help] section of the 
WIN.INI file.

Background Color
The default background color for the main window is the color the user defines 
using the Color application in the Windows Control Panel. However, the main 
window may appear with a custom background color if the author defines one for
the Help file (Figure 1.6).

Graphic
Authoring Predefined Attributes
Depending on the type of Help file you are creating, you may want to change 
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Help’s predefined defaults for the main window. For example, you may want to 
have the main Help window start up in a certain location on the screen when 
users request Help. Also, many types of information have different presentation 
requirements. Step-by-step procedures may work well in a tall, fairly narrow 
window. Tables of key equivalents, on the other hand, require a wider window. 
Other systems, like certain instructional models, require a fixed page size in 
which users view the information without scrolling.

Help authors can define any of the main window attributes discussed in this 
section:

n The window title
n The size of the window
n The location of the window
n The background color

Main window attributes are set in the [WINDOWS] section of the Help project 
file (see Chapter 16, “The Help Project File,” for details).

The Topic Area

In most applications for Windows, the part of the window where the user 
interacts with the computer and performs work is called the application 
workspace. In Windows Help, the workspace is where information is displayed. 
Help information is divided into “chunks” called topics. When you open a Help 
file, the topic (text and graphics) appears in the workspace of the main window 
(Figure 1.7).

Graphic

Note

If the Windows Help application is started without opening a 
Help file, the “Windows Help” logo appears in the topic area, and the 
button bar and scroll bars do not appear.

The Nonscrolling Region
Between the button bar and the scrolling region Help authors can create a 
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nonscrolling region of the main Help window. The nonscrolling region is simply 
a portion of the window that does not scroll with the rest of the topic information;
therefore, no scroll bars are necessary. If a vertical scroll bar displays in the topic,
it does not extend into the nonscrolling region. The nonscrolling region is 
separated from the scrolling region by a hairline (Figure 1.8).

Graphic
Because the nonscrolling region is an optional region that a Help author defines 
when creating the topic files, it may or may not appear in the Help window. If it 
does appear, it can contain the same kind of information as the scrolling region. 

The Scrolling Region
The part of the main window that contains the topic information is called the 
scrolling region. Text within the scrolling region wraps dynamically along the 
right edge of the window, even when the user changes the size of the window, 
unless the author creates nonwrapping text.

Scroll Bars
The scrolling region of the main Help window can include horizontal or vertical 
scoll bars. However, unlike Help version 3.0, scroll bars do not appear in the 
scrolling region unless they are necessary. Not displaying scroll bars gives Help 
authors more space in the scrolling region for Help information.

Windows Help determines whether to display scroll bars when the window is first
displayed and each time the user resizes the window. If the topic information 
extends below the lower window border, Help displays a vertical scroll bar 
(Figure 1.9).

Graphic
If the topic information extends beyond the right edge of the Help window, a 
horizontal scroll bar appears (Figure 1.10).

Graphic
Once a horizontal scroll bar appears, it remains in the topic, even if the user 
scrolls to another part of the topic that does not require a horizontal scroll bar.
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Note

Scroll bars behave independently in each Help window. 
Therefore, scroll bars that appear in the main window do not affect 
secondary windows.

Help scroll bars work the same as scroll bars in other Windows-based 
applications with one exception: information in the main window is not updated 
when the user drags the scroll box. Instead, Help updates the information only 
after the user stops moving the scroll box and releases the mouse button. This 
scroll-bar behavior is consistent with Windows-based applications that display 
large amounts of information in the main window, such as Word for Windows. 
For a complete description of the scroll bar interface, see “The Mouse and the 
Keyboard Interfaces” section later in this chapter.

Topic Text and Graphics
The scrolling and nonscrolling regions of the main Help window can display text 
and graphics, as well as other multimedia elements. These elements are created in
separate applications, such as word processors and paint programs, and are 
included in the Help file during the build process. Help merely serves as a display
engine for the text and graphics you create.

By controlling the way you create text and graphics, you control the way a topic 
looks to your users. Text attributes–font, point size, type style, color–are 
determined by Help authors when they create the topic files in a rich-text format 
(RTF) editor such as Word for Windows. The same is true for other elements. For
example, graphics can be full-size or reduced, complete or partial, full-color or 
monochrome (Figure 1.11).

Graphic
Topic Hot Spots
The scrolling and nonscrolling regions can include text and graphics that are 
“hot”–they provide links to other Help topics and to more information about the 
current topic.

Text hot spots are green and have either a solid or dotted underline. Graphics that
are hot have no special visual cue. However, whether text or graphics, the pointer
changes shape whenever it is over a hot spot (Figure 1.12).

Graphic
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To choose a hot spot

1. Position the pointer on the green text or hot graphic.
The pointer changes to a hand.
2. Click the mouse button once.
Or press TAB to highlight the hot spot, and then press ENTER.
Note     Do not double-click the mouse button when you choose a hot 
spot because Help processes both clicks separately. Depending on the 
Help file, the double-click may cause unexpected behavior, choosing 
two hot spots or executing a macro twice, for example.
Note     Pressing SHIFT+TAB highlights the hot spots in reverse order, 
and CTRL+TAB highlights all the hot spots within a topic 
simultaneously.
If the hot spot links to another topic, that topic appears in the Help 
window.
If the hot spot links to more information, Help displays the information 
in a pop-up window on top of the Help window. To close the pop-up 

window, click anywhere or press any key.
Windows Help has four standard menus: File, Edit, Bookmark, and Help. Menu 
commands open Help files, assist users as they navigate through and request 
information from Help files, or display Help on specific tasks.

Customizing the Menu Bar

The descriptions that follow refer to the standard Help menus and commands. 
Except for the How To Use Help command, you cannot modify the standard Help
menus or menu items. However, you can add additional menus and commands. 
Customizing the Help menu bar involves a number of Help macros, such as 
InsertMenu, InsertItem, DeleteItem, EnableItem, and others. For complete 
details about how to create your own custom menus and commands, see Chapter 
13, “Customizing the Help File,” and Chapter 15, “Help Macro Reference.”

Windows Help Menus
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The File Menu

Commands on the File menu let you open a Help file, print a topic, set up your 
printer, or quit Windows Help.

Open
The Open command opens an existing Help (.HLP) file.

You can open the Help file for any application that uses Help, even if you are not 
using the application. For example, you can be working in Notepad and open the 
Help file for Program Manager to read about using group windows.

If you currently have a Help file open, Help closes that file before opening the 
new file.

Help uses the File Open dialog box stored in the COMMDLG.DLL file if it is 
available on the user’s system. Otherwise, Help uses the 3.0 version of the Open 
dialog box.

To open a Help file

1. From the File menu in Help, choose Open.
The Open dialog box appears (Figure 1.13).

Graphic
2. If the file is on a different drive, select the drive you want from the 
Drives box.
3. In the Directories box, double-click the directory that contains the 
Help file.
Or press the UP ARROW or DOWN ARROW key to select the directory, and
then press ENTER.
4. In the File Name box, double-click the name of the Help file you 
want to open.
Or select the file, and then choose OK.
Instead of using the File Name and Directories boxes, you can type the 
complete path in the File Name box, and then choose OK.

Print Topic
The Print Topic command prints the text in the topic that is currently displayed in 
the main Help window.
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Help prints the entire topic, including graphics, but it does not print any 
annotations you might have made. If the topic has a nonscrolling region, it is 
printed at the top of the page. If the topic has an embedded window, the DLL is 
responsible for printing the information in the embedded window.

When a user prints a topic, Help displays a print status dialog box that contains 
the following information: Printing <topic title>. (Help uses the topic title text as 
defined in the title footnote.) If the topic does not have a name, Help displays 
“untitled” as the topic title. The user can continue printing or cancel the print job 
from this dialog box.

If you have connected to and installed a printer in Windows, Help prints to the 
default printer.

To print a Help topic

n From the File menu in Help, choose Print Topic.
The Print Topic dialog box appears while Help sends the topic 
information to the printer (Figure 1.14).

Graphic
To cancel printing

n Choose the Cancel button in the Printing dialog box.
Or press the ESC key.

Print Setup
The Print Setup command selects a printer for Help and changes printer setup 
information.

Help prints topics on the default printer. If you have installed more than one 
printer, you can make any of your installed printers the default printer. You can 
also change the default printer options. The available options in the dialog box 
depend on the type of printer you have connected to your computer.

Help uses the Print Setup dialog box stored in the COMMDLG.DLL file if it is 
available on the user’s system. Otherwise, Help uses the 3.0 version of the Print 
Setup dialog box. When using the version 3.0 dialog box, Help retains the version
3.1 menu command and Print Setup dialog box title rather than Printer Setup.

To set up a printer or change printer options



   Microsoft Windows Help Authoring Guide

1. From the File menu in Help, choose Print Setup.
The Print Setup dialog box appears (Figure 1.15).

Graphic
2. Select the options you want for this printer.
The options will vary depending on your installed printer.
3. If available, choose the Options button to select more options for the 
printer, and then choose OK when you have finished selecting options.
4. Choose OK.

Exit
The Exit command quits Windows Help.

When closing, Windows Help saves any annotations or bookmarks you have 
created.

To exit Help

n From the File menu in Help, choose Exit.
The Help window closes.

The Edit Menu

Commands on the Edit menu affect the text in the Help file, letting you copy a 
topic into a text editor or add notes to a Help topic.

Copy
The Copy command copies some or all of the text in a Help topic to the 
Clipboard. From the Clipboard, users can paste the text into another application 
or document. In this way, your Help system can provide examples and other 
information that the users might want to copy for themselves.

Choosing the Copy command places the text of the current Help topic in the Copy
dialog box. (This command does not copy graphics.) Line breaks are inserted at 
the end of each line, unless the topic was authored as nonwrapping.

In the Copy dialog box, you can select a portion of the topic text that you want to 
copy to the Clipboard, or you can copy the entire topic to the Clipboard by not 
selecting anything. If you make a selection in the Copy dialog box, only the 
selected text is copied to the Clipboard.
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Once displayed, the Copy dialog box can be moved and resized. Changes to the 
dialog box size or location are recorded in the [Windows Help] section of the 
WIN.INI file.

To copy text in the current Help topic to the Clipboard

1. From the Edit menu in Help, choose Copy.
The Copy dialog box appears (Figure 1.16).

Graphic
2. To copy all the text to the Clipboard, choose the Copy button.
Or select the text you want to copy to the Clipboard, and then choose 
the Copy button.
You can paste the text in the Clipboard into a Help annotation or into a 
document from another application.
You can also copy the entire contents of a Help topic directly to the Clipboard 
without displaying the Copy dialog box.

To copy the entire topic directly to the Clipboard

n Press CTRL+INS.

Annotate
The Annotate command attaches a note to the currently displayed topic. This 
feature lets users add their own comments to the information you provide in the 
Help file.

In the Annotate dialog box, you can type the annotation you want to add to the 
Help topic, edit an existing annotation, delete an annotation, copy all or part of an
annotation to the Clipboard, or paste the contents of the Clipboard into the 
annotation window.

When you save an annotation, Help places a paper-clip icon to the left of the 
topic title to remind you that you have added text to this topic. Clicking the paper-
clip icon opens the Annotate dialog box so that you can see the annotation.

Copy and Paste buttons are included in the Annotate dialog box so that users can 
select a portion of the text to copy to the Clipboard. Or they can copy the entire 
annotation to the Clipboard by not selecting anything. If they make a selection, 
only the selected text is copied to the Clipboard. The Paste button allows users to 
place information in the Clipboard and then paste it into the Annotate edit box 
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and save it with a topic. In this way, users can enhance their annotations with 
information from different sources. For example, a user might copy one Help 
topic to the Clipboard and then go to a different topic and paste the copied topic 
into an annotation to have the information from both topics accessible from one 
topic. The Paste button becomes active only when there is something in the 
Clipboard that might be pasted into the Annotate edit box.

Annotations are saved in a file with an .ANN extension. The annotation filename 
is based on the root name of the Help file and the annotation extension. For 
example, annotations to File Manager Help would be stored in the 
WINFILE.ANN file. Help stores annotation files in the user’s Windows 
directory. Annotations in the current Help file remain in effect between Windows
Help sessions.

Once displayed, the Annotation dialog box can be moved and resized. Changes to
the dialog box size or location are recorded in the [Windows Help] section of the 
WIN.INI file.

To add an annotation to the current Help topic

1. From the Edit menu in Help, choose Annotate.
The Annotate dialog box appears (Figure 1.17).

Graphic
2. Type the text you want to add.
If you make a mistake, press BACKSPACE to erase any unwanted 
characters, and then continue typing.
Text wraps automatically in the edit box, but you can end a line before 
it wraps by pressing ENTER.
3. When you have finished creating the annotation, choose the Save 
button.
A paper-clip icon appears in the topic title, indicating that you have 
made an annotation (Figure 1.18).

Graphic
To view an annotation

1. Go to the topic where you made the annotation.
2. Click the paper-clip icon.
Or press TAB to highlight the paper-clip icon, and then press ENTER.
3. When you have finished reading the annotation, choose the Cancel 
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button.

To remove an annotation

1. Go to the topic where you made the annotation you want to delete.
2. Click the paper-clip icon.
Or press TAB to highlight the paper-clip icon, and then press ENTER.
3. Choose the Delete button.
You can also copy text from an annotation and paste it into another annotation or 
into another document. Likewise, you can paste text from other documents into 
annotations.

To copy an annotation

1. Go to the topic where you made the annotation you want to copy.
2. Click the paper-clip icon.
Or press TAB to highlight the paper-clip icon, and then press ENTER.
3. To copy the entire annotation to the Clipboard, choose the Copy 
button or press CTRL+INS.
Or select the text in the annotation that you want to copy to the 
Clipboard, and then choose the Copy button.
4. To close the Annotate dialog box, choose the Save button.

To paste an annotation

1. Copy to the Clipboard the text that you want to paste into the 
annotation.
2. Go to the topic where you want to paste the annotation.
3. Click the paper-clip icon.
Or press TAB to highlight the paper-clip icon, and then press ENTER.
4. To paste the contents of the Clipboard at the beginning of the topic, 
choose the Paste button or press SHIFT+INS.
Or place the insertion point where you want to insert the new text, and 
then choose the Paste button.
5. To save the changes and close the Annotate dialog box, choose the 
Save button.
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The Bookmark Menu

Commands on the Bookmark menu create and remove bookmarks placed at 
specific Help topics. The Bookmark menu initially contains one command: 
Define. As users define bookmarks, they are added to the menu until a total of 
nine appear. Help then adds a More command to give the user access to the 
additional bookmarks.

Define
The Define command places a bookmark in the Help file at the current topic or 
removes a bookmark from a topic. Just as you can place bookmarks in a book to 
mark specific references, you can place bookmarks at Help topics you use 
frequently. When you place a bookmark at a topic, you can get that topic quickly 
from Help’s Bookmark menu.

In the Bookmark Define dialog box, you can type the name you want to assign to 
the bookmark, edit the suggested name, or delete a bookmark. When you define a
bookmark, Help suggests the topic title as the bookmark name. You can use the 
default name or type your own name in the edit box. If the topic does not have a 
title, you must type your own bookmark name for it. When you save the 
bookmark, Help adds the bookmark name to the Bookmark menu and records the 
topic title and the user’s location within the topic for future reference. The Delete
button in the dialog box lets you remove any bookmark that appears in the 
bookmark list box.

After you define a bookmark, you can choose the bookmark name from the 
Bookmark menu to move directly to the topic.

Help saves all user-defined bookmarks in the WINHELP.BMK file. Bookmarks 
are saved to a global file to make it easy for users to return to any marked 
location in any Help file. Help stores WINHELP.BMK in the user’s Windows 
directory. Bookmarks remain in effect between Windows Help sessions.

Bookmarks may or may not be compatible across different versions of a product. 
For example, if a user upgrades the Windows Help application from version 3.0 
to version 3.1, all defined bookmarks will remain valid. However, if a user 
upgrades the Help file that uses the bookmarks, the bookmarks may become 
invalid. If the new Help file has many changes–added and removed topics–the 
bookmarks will go to the wrong places. Therefore, it is best to remove a 
user’s .BMK file when your setup program installs a new version of the Help file.
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To place a bookmark at the current topic

1. From the Bookmark menu in Help, choose Define.
The Bookmark Define dialog box appears (Figure 1.19).

Graphic
2. Type the name you want to give to the bookmark in the Bookmark 
Name box, and then choose OK.
Or just choose OK to use the topic title as the bookmark name.
The bookmark name now appears on the Bookmark menu in Help 
(Figure 1.20).

Graphic
To remove a bookmark

1. From the Bookmark menu in Help, choose Define.
2. Select the bookmark you want to remove.
Or type the bookmark name in the edit box.
3. Choose the Delete button.
The bookmark name is removed from the bookmark list box and from 
the Bookmark menu.

Bookmark Names
After a user defines a bookmark, its name appears on the Bookmark menu so that
the user can go directly to the bookmarked topic. The first nine bookmarks are 
listed on the Bookmark menu in the order that they are created. The number 
appearing to the left of the item name provides the keyboard access.

To go to a bookmarked topic

n From the Bookmark menu, choose the name of the bookmarked topic
you want to view.
Underlined numbers precede the first nine bookmark names. You can 
press the corresponding number key to go quickly to a marked topic.

More
The More command appears as the last item on the Bookmark menu when you 
have defined more than nine bookmarks.
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Choosing More displays the Bookmark dialog box, which contains a list of all the
bookmarks you have defined in the current Help file. Help selects the first item in
the bookmark list when the dialog box opens.

To choose from the complete list of bookmarked topics

1. From the Bookmark menu in Help, choose More.
The Bookmark dialog box appears (Figure 1.21).

Graphic
2. In the Go To Bookmark box, double-click the name of the 
bookmarked topic you want to view.
Or select the bookmark name, and then choose OK.

The Help Menu

Commands on the Help menu display the How To Use Help file for Windows 
Help, place Help windows on top of other application windows, and identify the 
Help application.

How To Use Help
The How To Use Help command displays the Contents screen of the Help file for
Windows Help (WINHELP.HLP). This file provides instructions on how to use 
the Windows Help application and Help topics.

If the user opens Help as a stand-alone application, choosing this command 
displays the How To Use Help file in a second Help window. This second Help 
window remains open until the user closes it or until the user closes the first 
instance of Help (if there are no other instances of the Help window open).

In Windows Help version 3.1, Help authors can create their own How To Use 
Help file instead of using the default file by using the SetHelpOnFile macro in 
the [CONFIG] section of the Help project file. Replacing the standard file is 
important if you want the instructional file to reflect the particular features of 
your application’s Help system. 



The Windows Help Application§   1-17
Note

Use the SetHelpOnFile macro to specify a custom How To Use
Help file, the DeleteItem macro to remove the standard How To Use 
Help item, and the InsertItem macro to place the new menu item on 
the Help menu. See Chapter 15, “Help Macro Reference,” for 
information about each of these macros and Chapter 16, “The Help 
Project File,” for information about how to use them in the [CONFIG] 
section of the Help project file.

To learn how to use the Help application

n From the Help menu, choose How To Use Help.
Help displays the Contents topic of the standard file or of a custom 
How To Use Help file if one has been authored (Figure 1.22).

Graphic
Always On Top
The Always On Top command causes all Help windows to appear on top of other
application windows on the screen. If you minimize a window that is on top, its 
icon also appears on top of other windows.

Note

Other applications that use the topmost attribute, such as 
Windows Task List, may compete with Help for the top position. In 
that case, the Help window may appear beneath another window.

When you first ask for Help, the Help window appears on top of other windows 
on the screen. If you click inside another window, the Help window goes behind 
and the window you clicked appears on top.

You can choose to keep the Help window on top of other windows even when 
switching to other application windows. This can be especially useful if you are 
using Help to follow a step-by-step procedure in your application.
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Note

This command is available only with Windows version 3.1.

To make the Help window stay on top

n From the Help menu, choose Always On Top.
A checkmark appears next to the command, and a 2-pixel drop shadow 
appears around the window border to indicate that the Help window is 
on top (Figure 1.23)

Graphic
To return Help to normal window behavior

n From the Help menu, choose Always On Top again.
Note
If the Always On Top command is not checked, a secondary window 
that has been defined as an on-top window may remain on top. The 
main Help window can be made on top only by choosing this 
command.

About Help
The About Help command displays a dialog box that identifies the Windows Help
application. It includes the Help application name, the Help icon, the version 
number, and the Microsoft Help copyright notice. In addition, the dialog box lists 
information about the user and the user’s hardware configuration.

Using the COPYRIGHT option in the Help project file, you can provide a 
custom copyright notice or other message about your application’s Help file. For 
details, see Chapter 16, “The Help Project File.”

Help uses the About Help dialog box stored in the SHELL.DLL file if it is 
available on the user’s system. Otherwise, Help uses the 3.0 version of the About 
Help dialog box.

To see information about Windows Help

n From the Help menu, choose About Help.
The About Help dialog box appears (Figure 1.24).
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Graphic
Windows Help has four standard buttons: Contents, Search, Back, and History. 
The buttons appear in the button bar, just below the menu bar in the Help 
window. The standard buttons function as navigation controls, helping users 
access the information in the Help file (Figure 1.25).

Graphic
To choose a Help button

n Click the button you want.
Or press the underlined letter in the button name.
The Help button bar in version 3.1 is different from the version 3.0 button bar in 
two ways: the Browse buttons (<< and >>) have changed from standard buttons 
to optional buttons, and the buttons have changed from graphical buttons to text-
only buttons. The latter change was necessary because:

n Text-only buttons are half as large as graphical buttons, so more 
information fits in the Help window.

n Text-only buttons reduce the size of the Help application 
(WINHELP.EXE), giving you more space for your Help file.

n Text-only buttons simplify the process of adding custom buttons to 
the interface and of translating the existing buttons into foreign 
languages for international markets of your application and Help.

The Help button bar behaves the same as a standard menu bar: buttons wrap if the
window becomes too narrow to fit all the buttons horizontally. The buttons 
continue to wrap until they are all stacked vertically. If the buttons still do not fit 
in the window, Windows Help reduces the size of the buttons and truncates the 
button text, if necessary.

The Windows Help Button Bar
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Customizing the Button Bar

The descriptions that follow refer to the standard Help buttons. You cannot 
remove the standard Help buttons. However, you can change the function of the 
standard buttons or add additional buttons to the button bar. Help authors can 
create up to 16 additional buttons for a total of 22 buttons (including Browse 
buttons).

Custom buttons can have as many as 29 characters, after which Help truncates 
the button name. Help determines the size of all the buttons based on the longest 
name and the default button size (determined by the longest standard button 
name–Contents). So if you assign long button names to custom buttons, the size 
of all the buttons in the button bar will increase.

Customizing the Help button bar involves a number of Help macros, such as 
ChangeButtonBinding to modify the standard buttons, CreateButton, 
DestroyButton, EnableButton, and others to create and modify custom buttons. 
For complete details about how to create your own custom buttons, see Chapter 
13, “Customizing the Help File.”

The Contents Button

The Contents button is the first, or leftmost, button in the Help button bar. 
Choosing the Contents button displays the topic designated by the Help author as 
the Help Contents (usually the top-level topic in a Help file). If the author does 
not specify a contents topic by using the Contents= entry in the [OPTIONS] 
section of the Help project file, Windows Help displays the first physical topic in 
the Help file (the first topic in the first .RTF file listed in the [FILES] section of 
the Help project file).

The purpose of the Contents button in Windows Help version 3.1 is to create a 
consistent navigation point within a single Help file and across all Windows-
based applications that use Help. When using hypertext systems, users often feel 
lost and need a way to reorient themselves in this abstract “hyperspace.” The 
Contents button gives users an easy way to return to a familiar starting place.

Note

When displaying a version 3.0 Help file, Help uses the Index= 
entry as the Contents topic.

All applications included with Windows version 3.1, such as Program Manager, 
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File Manager, Write, and so on, have a Contents command on the Help menu. 
Choosing the Contents command from an application’s Help menu is the same as 
choosing the Contents button in the Help button bar.

To see the Contents topic of the current Help file

n Choose the Contents button.

The Search Button

Windows Help lets users search for Help information by keyword, which is 
similar to searching through a book index. The purpose of the Search button in 
Windows Help version 3.1 is to create a consistent way to create an online index 
for Help files. Book indexes have proven to be very effective ways for people to 
look up information. In an electronic document, such as a Help file, users also 
need an easy way to find specific information. The Search button gives users the 
electronic equivalent of a book index.

Users search for information by looking up the keywords an author has defined 
for the Help topics. For example, a user might look up all the topics that have the 
keyword “save” associated with them. Those topics should provide information 
about saving different kinds of items, such as files and documents (Figure 1.26).

Graphic
The Search dialog box has an edit field, two list boxes, and three command 
buttons:

n The edit box is used to type a keyword for the search. As the user 
types in the edit field, the keyword list scrolls automatically to match
the user’s entry or the closest letter to that entry. For example, typing
the letter S scrolls the keyword list to the first keyword beginning 
with S. The keyword highlight moves forward in the list box 
whenever it has a match closer to what the user is typing. If a user 
performs a search and goes to the topic, the previous search keyword 
will be entered automatically in the edit box.

n The top list box contains all the keywords in the Help file. Six 
keywords show in the list box at one time. Clicking a keyword in the 
list box enters it in the edit box. Double-clicking an entry selects the 
keyword and performs the search.
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n The Show Topics button performs the search using the keyword in 
the edit box. A user can press ENTER after selecting a keyword.

n The lower list box shows all the topics found by the search. 
Approximately seven entries will fit in the list box. If more topics are
found, the user can scroll to see more topics. Clicking a topic selects 
it. Double-clicking a topic title displays that topic (same as selecting 
the topic and choosing Go To).

n The Go To button displays the topic the user has selected in the 
Topics Found list box and closes the Search dialog box. After a user 
chooses Show Topics, the user can press ENTER again to go to the 
topic. This double-return action in the dialog box allows for quick 
searches. Or, users can search quickly by typing a keyword and 
pressing ENTER twice to go to the first topic displayed in the Topics
Found list.

n The Cancel button dismisses the dialog box. (The Cancel button 
changes to Close if the user has already performed a search.)

Users can move the Search dialog box if they want. Changes to the dialog box 
location are recorded in the [Windows Help] section of the WIN.INI file.

All applications included with Windows version 3.1, such as Program Manager, 
File Manager, Write, and so on, have a Search For Help On command on the 
Help menu. Choosing the Search For Help On command from an application’s 
Help menu is the same as choosing the Search button in the Help button bar.

To search for a Help topic by keyword

1. Choose the Search button.
The Search dialog box appears (Figure 1.27).

Graphic
If the user has performed a search during this session, the previous 
keyword is displayed in the edit box.
2. Type a keyword, or select one from the keyword list.
You can use your keyboard to move quickly to different parts of the 
list. The list scrolls to those keywords that most closely match what you
are typing in the text box.
3. Choose the Show Topics button.
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A list of topics associated with that keyword appears in the lower list 
box, as in Figure 1.28.

Graphic
4. Select the topic you want, and then choose the Go To button to jump 
to the selected topic.
Or double-click the topic you want.

The Back Button

The Back button has the same functionality as in Help version 3.0: it keeps track 
of every topic users look at from the time they open Help until they close it and 
stores these topics in a “back” list. Choosing the Back button displays the topic 
that was previously displayed in the Help window (Help goes back one item in 
the back list). Choosing Back repetitively causes Help to back up one screen at a 
time along the path the user has followed.

In other words, Back lets users go back to topics they have already viewed, in the
order they viewed them, without forcing them to remember anything about the 
topic or how they got there. Back simply retraces the steps the user has taken. So,
in one sense, Back is like a screen recorder and playback mechanism combined 
into a single button. 

Back functions in the current file as well as across files, so if a user opens or 
jumps to a different file, backing up reopens an inactive file to display a 
previously viewed topic. However, the Back list is cleared when the user closes 
Help. If there is no previous topic to view, the Back button is dimmed.

To go back to the previous topic

n Choose the Back button.

To back up to a previously viewed topic

n Choose the Back button repeatedly until you return to the topic you 
want to see.

The History Button

Choosing the History button displays a window that shows the topics (a 
maximum of 40) you have viewed during the current session. You can select any 
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topic from the list to view it again (Figure 1.29).

Graphic
The purpose of the History button is to give users a visual representation of the 
topics that they have viewed during a session and let them return easily to any of 
those topics. Because the space that users navigate in hypertext systems is 
abstract and nonlinear, they often suffer from disorientation. As users move 
through the information, however, they create a linear path. The history list 
records this linear movement and lets users visualize the path they have taken 
through the information and return quickly to a particular place. In this sense, 
History is similar to Back in that they both are “backtracking” devices. But 
because the History window presents this path visually and stays open while 
users interact with it, History offers advantages to the browsing user.

Windows Help uses the following guidelines to build the history list:

n The topic title of the topic displayed in the Help window when the 
user chooses the History button appears first in the history list.

n The second item in the history list is selected when the user chooses 
the History button so that the user can just press ENTER to return to 
the previous topic. This gives History the same functionality as Back.

n Each entry in the history list occupies one line. If the topic title does 
not fit in the History window, it is truncated rather than wrapped.

n The history list records the user’s location within a topic as well as 
the topic title, even though only the title appears in the list. When 
users choose an item from the history list, Help returns them to the 
exact place in the topic where they were when they left it (scrolled 
half-way down, for example).

n The history list records only topics that are displayed in the main 
Help window. Topics displayed in secondary windows or pop-up 
windows do not appear in the history list.

n The history list records only jump-type movements in Help. Hot-spot
events such as launching an application or a tutorial are not recorded.
Movements caused by using the Back button or requesting How To 
Use Help are recorded, however.

n Help does not remove duplicate entries from the history list. If a user 
views a topic several times, each instance appears in the history list.
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n Help maintains the history list across Help files. If the user chooses 
an interfile jump, the history list prefixes the root name of the Help 
file before the topic title.

When a user chooses a topic from the history list, the History window does not 
close, but it loses the focus. To switch back to the History window, the user can 
click inside the window, choose the History button, or press ALT+F6. To cancel 
the History window without choosing a topic, the user can choose the Close 
command from the Control menu or press ALT+F4. If the user minimizes the 
main Help window, the History window closes, and restoring the Help window 
does not restore the History window. The user must choose the History button 
again to restore the History window.

The default size of the History window is approximately one-third the height and 
width of the screen. The default position is centered. Once displayed, the History 
window can be moved and resized. If the user changes the size or location of the 
History window, it will retain those changes the next time it appears. Changes to 
the window’s size or location are recorded in the [Windows Help] section of the 
WIN.INI file. 

To use the History button to return to a topic

1. Choose the History button.
The History window appears (Figure 1.30).

Graphic
2. Double-click the topic to which you want to return.
Or select the topic and press ENTER.
If necessary, use the scroll bar to see more topics.

Browse Buttons

The Browse buttons, which were standard in Help version 3.0, are now optional 
in version 3.1. Even though they are optional buttons, they can be considered as 
standard buttons because they are a feature of the Windows Help application. The
Browse buttons have been made optional because Microsoft feels that this 
functionality can often be better presented in the context of the topic information 
rather than as part of the Help application. It is up to each individual author to 
decide whether to include the standard Browse buttons or create a unique, custom
browsing feature in their Help system.
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Browse buttons can be included as part of the standard Windows Help button bar 
by adding the BrowseButtons macro to the [CONFIG] section of the Help 
project file. For more information about adding the Browse buttons, see Chapter 
15, “Help Macro Reference,” and Chapter 16, “The Help Project File.” The 
procedure for creating browse sequences within the topic files has not changed 
from version 3.0 to 3.1. See Chapter 6, “Creating Topics,” for the authoring 
information.

If the author includes the Browse buttons in the Help file, or if Help opens a 
version 3.0 Help file, the Browse buttons are displayed to the right of the four 
standard buttons (Figure 1.31).

Graphic

Note

When displayed in Windows Help version 3.1, version 3.0 files 
use the 3.1 text-only buttons rather than the graphical buttons seen in 
version 3.0.

To browse to the previous topic in a browse sequence

n Choose the Browse << button.

To browse to the next topic in a browse sequence

n Choose the Browse >> button.
When working with Help files, you might want to alter the look and behavior of 
Windows Help. You can customize Help by:

n Creating a program item to start Help and a specific Help file.
n Starting Help from MS-DOS.
n Changing the standard Help icon to a custom icon.
n Changing Help’s default color scheme.

Customizing the Help Application
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The following sections explain how to customize the way Windows Help looks 
and works.

Creating a Program Item for Your Help File

While you are creating your own Help file, you may want to have a more 
customized setup for starting Help. The best thing to do is to create one or more 
program items in a Program Manager group that will start Help and, if you want, 
a specific Help file.

To create a program item for the Help application
1. In Program Manager, open the group where you want to add the Help
item.
2. Press and hold down the ALT key while double-clicking a blank area 
of the group window.
The Program Item Properties dialog box appears.
3. Fill in the Program Item Properties dialog box as necessary, and then 
choose the OK button. 
For help with the Program Item Properties dialog box, choose the Help 
button in the dialog box. 
You can specify any of the command-line options for starting Help in 
the Command-Line box. See the next section for details.

Starting Help from the MS-DOS Command Line

You can start Windows Help directly from the command line in MS-DOS, or you
can use command-line options within Windows to start Help using a program 
item or using the Run command in Program Manager.

To start Help without opening a Help file, type:

c:\windows\winhelp

To start Help and open a specific Help file, add the Help file name after Help:

c:\windows\winhelp myhelp.hlp

If the Help file is located on a network server, specify the network path to the 
file:

l:\\server\share\help\winhelp myfile.hlp
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Use the -n option followed by a context ID number to start Help and display a 
topic with a context ID that you have defined in the [MAP] section of the Help 
project file:

c:\windows\winhelp -n 801 pifedit.hlp

Use the -i option followed by a context string to start Help and display a topic 
with the context string identifier that you have assigned using the pound footnote 
(#):

c:\windows\winhelp -i cg_how_pm progman.hlp

Changing the Standard Help Icon

The standard Windows Help icon is a yellow question mark. You can replace this
icon with a custom icon; use any .ICO icon file that you create with Windows 
Imagedit or another icon program.

To change the Help icon
1. Open the group in Program Manager that contains the Help program 
item and select the Help icon.
2. From the File menu, choose Properties.
3. In the Program Item Properties dialog box, choose the Change Icon 
button.
4. If more than one icon is available in the Current Icon area, scroll 
through the icons by clicking the scroll arrows or by using the LEFT 
and RIGHT ARROW keys.
If you would like more icons to choose from, you can scroll through all 
the available Program Manager icons. Or you can use the Browse 
button to select an icon from a directory on your hard disk or floppy 
drive, if you have other icons to choose from.
5. When the icon you want to use is selected, choose OK.
6. In the Program Item Properties dialog box, choose OK. 

Changing Help’s Default Color Scheme

Because Windows Help is a standard Windows-based application, users can 
modify its default appearance the same way they modify the look of Windows–by
using the Control Panel Colors setting to change their screen colors. Control 
Panel lets users change the color of the standard Help window elements: title bar, 
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menu bar, button bar, scroll bars, window background, window text, and window 
border. In addition to these standard window elements, Help has two special 
elements: hot-spot text and the Help startup screen. By default, text hot spots in 
Help are green and the startup screen is blue. Windows Help provides custom 
WIN.INI entries that users can use to modify these two visual elements of Help.

Note

Generally, applications should not change any of the WIN.INI 
settings described in this section because they are global settings 
designed for end users. They are not provided so that an application’s 
setup program can edit the WIN.INI file and insert or update these 
settings during installation of their product. If an application wants to 
change the way hot spots appear in Help, it should use the authoring 
procedures described in Chapter 8, “Creating Links and Hot Spots.”

Changing Hot-Spot Colors
If users want to change the way hot spots appear in Help, they can edit the 
Windows WIN.INI file and specify custom hot-spot colors. Help supports the 
following WIN.INI entries:

[Windows Help]
JumpColor=(RRR, GGG, BBB)
PopUpColor=(RRR, GGG, BBB)
MacroColor=(RRR, GGG, BBB)
IFJumpColor=(RRR, GGG, BBB)
IFPopUpColor=(RRR, GGG, BBB)
RRR, GGG, and BBB represent the red, green, and blue (RGB) components of 
the hot-spot color. These color values can be a number from 0 to 255. The 
meaning of each entry is explained in the following table.

Command Defines the color for Default color

JumpColor Jump hot spots Green

IFJumpColor Interfile jump hot spots Same as JumpColor
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PopUpColor Pop-up hot spots Same as JumpColor

IFPopUpColor Interfile pop-up hot spots Same as JumpColor

MacroColor Macro hot spots Same as JumpColor

To change the color of Help hot spots

1. Open the WIN.INI file in Notepad or some other text editor.
2. Go to the [Windows Help] section.
3. Type one or more of the hot-spot color entries.
Note     You can specify just the JumpColor entry to change the color 
of both jump and pop-up hot spots.
4. Save the WIN.INI file and exit the text editor.
5. Restart Windows to have your changes take effect.
When you open Help again, your hot-spot colors will be set to the 
colors you specified.

Overriding Author-Defined Hot-Spot Colors
As Chapter 8 explains, Help authors can also change the color of hot-spot text. 
These author-defined colors may cause problems for some users (those with gas 
plasma VGA screens, for example), making it difficult or even impossible to read
the hot-spot text. If the Help file contains an author-defined color for hot spots, 
the above entries will have no effect. To override an author-defined hot-spot 
color, users can type the following entry in the WIN.INI file:

[Windows Help]
Colors=NONE
If Help finds this entry in the WIN.INI file, it uses the system default colors for 
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foreground and background colors, regardless of how the Help file was authored.

Chapter 8, “Creating Links and Hot Spots,” explains how Help authors can 
change the default appearance of hot spots.

Changing Help’s Startup Screen Colors
When you start the Windows Help application without opening a Help file, Help 
displays a startup logo that identifies itself. If users want to change the starting 
and ending colors used in the Help logo screen, they can edit the WIN.INI file. 
Help supports the following WIN.INI entries:

[Windows Help]
LogoStart=(RRR, GGG, BBB)
LogoEnd=(RRR, GGG, BBB)
As with the hot-spot entries, you specify the RGB color you want for the logo 
screen color on the right side of the equal sign (a number from 0 to 255). The 
meaning of each entry is explained in the following table.

Command Defines the color for Default color

LogoStart Windows Help startup logo screen Blue

LogoEnd Windows Help ending logo screen Blue

You can use the mouse or the keyboard to work with Help, or you can use a 
combination of the two. The following sections provide details about both 
interfaces.

The Mouse and the Keyboard Interfaces
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Mouse Interface

Windows Help uses the standard mouse interface for common actions: choosing 
commands, moving or resizing the Help window, choosing buttons, interacting 
with dialog boxes, scrolling information, and choosing hot spots. There are, 
however, some of anomalies in the mouse interface.

The first involves choosing hot spots. In many Windows-based applications, the 
user must double-click the mouse to execute an action. This is true in Help also. 
To choose a topic from the History window, you can double-click the topic. But 
this is not true with hot spots. Choosing a hot spot requires only one mouse click. 
Using a double-click to choose a hot spot may result in a double action. For 
example, double-clicking a jump may cause Help to execute an action in the two 
topics: the one containing the jump and the one that is displayed as a result of the 
jump.

The second difference involves scrolling. In many application windows and list 
boxes, the information in the window or list box is updated as the user moves the 
scroll box. In the main Help window, information is not updated when the user 
moves the scroll box. Instead, the information is updated only when the user 
finishes moving the scroll box and releases the mouse button.

Scrolling with the Mouse
Use the following techniques to scroll text within the Help window.

To scroll Do This

Up or down one line Click the up or down scroll arrow on the vertical 
scroll bar.

Right or left one line Click the right or left scroll arrow on the 
horizontal scroll bar.

Up or down one window Click the vertical scroll bar above or below the 
scroll box.
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Right or left one window Click the horizontal scroll bar to the right or left 
of the scroll box.

Continuously Point to one of the scroll arrows, and hold down 
the mouse button until the information you want 
comes into view.

To a particular place in the topic Drag the scroll box to the position you want.

Keyboard Interface

As in other Windows-based applications, Help provides keyboard equivalents for 
most mouse actions. The following tables describe the keys you can use in Help.

Help Access Keys
Use the following keys to get Help from the application.

To Press

Start Help and display the Contents for the application. If the Help 
window is already open, pressing F1 displays the Contents for the How 
To Use Help topics.

If the application provides context-sensitive Help (such as Program 
Manager and File Manager), pressing F1 displays a Help topic on the 
selected command or dialog box option.

This feature is available only if the application supports it. It is available 
in all of the applications included with Windows.

F1

Change to Help mode so you can choose the command, click the screen 
region, or press the key or key combination on which you want Help.

This feature is available only in certain applications (such as Microsoft 

SHIFT+F1
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Word for Windows). It is not available in any of the applications 
included with Windows.

Help Button Keys
Use the following key equivalents for the Help buttons.

To Press

Display the Help Contents for the application C

Display the Search dialog box, which lists all the search keywords for the
application

S

Go back to the last topic you viewed B

Display the History window, which lists the last 40 topics you have 
viewed

T

Display the next topic in a browse sequence (Optional Browse >> 
button)

period (.)

Display the previous topic in a browse sequence (Optional Browse << 
button)

comma (,)
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Help Window Keys
Use the following keys while working in Help.

To Press

Select a hot spot. Pressing TAB repeatedly moves you clockwise to 
other hot spots in the topic.

TAB

Select a hot spot. Pressing SHIFT+TAB repeatedly moves you 
counterclockwise to other hot spots in the topic.

SHIFT+TAB

Select all the hot spots in a topic. CTRL+TAB

Copy the entire contents of the current Help topic directly to the 
Clipboard without displaying the Copy dialog box. Or copy an entire 
annotation or a portion of it to the Clipboard.

CTRL+INS

Paste the contents of the Clipboard into the Annotation dialog box. SHIFT+INS

Switch between the main Help window and the History window. ALT+F6

Close the Help window. ALT+F4
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Help Movement Keys
Use the following keys to scroll text within the scrolling region of the Help 
window.

To scroll Press

Up one line UP ARROW

Down one line DOWN ARROW

Right one character RIGHT ARROW

Left one character LEFT ARROW

To the leftmost position HOME

To the rightmost position END

To the first line in the scrolling region of the topic CTRL+HOME
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Up one window PAGE UP

Down one window PAGE DOWN

To the beginning of the topic CTRL+PAGE UP

To the end of the topic CTRL+PAGE DOWN
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	n The history list records the user’s location within a topic as well as the topic title, even though only the title appears in the list. When users choose an item from the history list, Help returns them to the exact place in the topic where they were when they left it (scrolled half-way down, for example).
	n The history list records only topics that are displayed in the main Help window. Topics displayed in secondary windows or pop-up windows do not appear in the history list.
	n The history list records only jump-type movements in Help. Hot-spot events such as launching an application or a tutorial are not recorded. Movements caused by using the Back button or requesting How To Use Help are recorded, however.
	n Help does not remove duplicate entries from the history list. If a user views a topic several times, each instance appears in the history list.
	n Help maintains the history list across Help files. If the user chooses an interfile jump, the history list prefixes the root name of the Help file before the topic title.
	1. Choose the History button.
	2. Double-click the topic to which you want to return.


	Browse Buttons
	n Choose the Browse << button.
	n Choose the Browse >> button.
	n Creating a program item to start Help and a specific Help file.
	n Starting Help from MS-DOS.
	n Changing the standard Help icon to a custom icon.
	n Changing Help’s default color scheme.

	Creating a Program Item for Your Help File
	1. In Program Manager, open the group where you want to add the Help item.
	2. Press and hold down the ALT key while double-clicking a blank area of the group window.
	3. Fill in the Program Item Properties dialog box as necessary, and then choose the OK button.

	Starting Help from the MS-DOS Command Line
	Changing the Standard Help Icon
	1. Open the group in Program Manager that contains the Help program item and select the Help icon.
	2. From the File menu, choose Properties.
	3. In the Program Item Properties dialog box, choose the Change Icon button.
	4. If more than one icon is available in the Current Icon area, scroll through the icons by clicking the scroll arrows or by using the LEFT and RIGHT ARROW keys.
	5. When the icon you want to use is selected, choose OK.
	6. In the Program Item Properties dialog box, choose OK.

	Changing Help’s Default Color Scheme
	Changing Hot-Spot Colors
	1. Open the WIN.INI file in Notepad or some other text editor.
	2. Go to the [Windows Help] section.
	3. Type one or more of the hot-spot color entries.
	4. Save the WIN.INI file and exit the text editor.
	5. Restart Windows to have your changes take effect.

	Overriding Author-Defined Hot-Spot Colors
	Changing Help’s Startup Screen Colors

	Mouse Interface
	Scrolling with the Mouse

	Keyboard Interface
	Help Access Keys
	Help Button Keys
	Help Window Keys
	Help Movement Keys



